Pod2g has just announced via Twitter that he has a fully functional, untethered jailbreak for iOS 5.0.1. This comes a day after we posted about how to downgrade to iOS 5.0 without SHSH Blobs being saved, in order to guarantee an untethered later on. That process isn’t really necessary now, because iOS 5.0.1 is going to get it too!

It was originally announced that users should stay away from iOS 5.0.1, so that they would have a better chance at the jailbreak in the future. Pod2g, as well as many members of the Dev Team, warned us all that updating to iOS 5.0.1 would make things more difficult later. As always, you shouldn’t ever update your device, unless you hear from official sources that it is safe to do so. Those who value their ability to jailbreak, are the people who should be paying attention the most.

It’s important to note that those people who are still wanting an UNLOCK for their devices should still stay where they are. It isn’t important to have every single update from Apple, in fact, it’s counter-intuitive to your goals as a person who’s trying to get away with breaking the rules. If you are satisfied with your device, and you have a fully functional phone that serves it’s purpose well… don’t jeopardize it with trying to update the device. That’s when things go wrong, and that’s when you come to us (or other places) for help. If you’re already jailbroken with an untethered jailbreak, don’t worry about it yet.

An important note to take from this, is that pod2g doesn’t own a device which utilizes the A5 chip. That means, he doesn’t have an iPhone 4S, or an iPad 2, so neither of these devices have had any testing with this jailbreak. Those devices should be considered “exempt” from this post. Older devices… this applies to you.

It’s recommended, however, that you still save your SHSH Blobs/ apticket for iOS 5.0 before you go, using iH8sn0w’s iFaith software, found HERE. Then, go ahead and save them again when you are on the new firmware.

THERE IS NO OFFICIAL RELEASE DATE SET FOR THIS TO BECOME PUBLIC… PLEASE DON’T ASK.

Simple story. If you need an unlock, don’t touch iOS 5.0.1, or really any future firmware in which it’s unable to preserve the baseband. If you are unsure, just lay low, or ask us on Facebook. – If, however, you are one of those lucky people who chose a carrier over a device, and don’t need it unlocked, but would like a jailbreak later still… It’s safe. Go get it. :D

[EDIT: I apparently didn’t make it clear enough, so allow me to add something. If you are already on an untethered jailbreak, updating will cause you to lose it. This isn’t available yet, but it’s now confirmed to work on the firmware. Since no release is available yet, updating now will cause you to lose the jailbreak that you have. – It’s meant for those who are waiting for it to happen. It’s meant for people who don’t have an untethered jailbreak, and are hopeful for one in the future.]

HotTips! Readers: Get Great VPS Wordpress Hosting Cheap!

HotTips! Readers can enjoy great savings with a hosting package at Pryor Media! Your WordPress website will never be that slow-loading junk that you get with shared hosts! Learn what makes Pryor Media’s WordPress Hosting different from the rest, and use coupon code “HOTTIPS” to save 20% off of your hosting subscriptions!

Learn More Here